Use of CLv1 and CLv2

(Amy Silcock) #1

With the upcoming deprecation of version 1 of the IATI Standard there’s a question over what happens to codelist versions.

Currently there are three types: CLv1, CLv2 and CLv3. Each codelist version has slightly different formatting, and can be accessed by the codelist api.

Please can share if you are using version CLv1 and/or CLv2. If yes, do you have plans to change onto CLv3 before/once version 1 of the IATI Standard has been deprecated? And if not, why not?

I’m reaching out to the techies here. Please do let me know and do share with others.

@andylolz @markbrough @siemvaessen @rolfkleef @matmaxgeds @bibhusan @AkermanMartin @shi @Eimis @Herman @JohnAdams @stevieflow @stolk

3 Likes
(Matt Geddes) #2

V3 only here - but wanting to say thanks for the good process :slight_smile:

5 Likes
(Andy Lulham) #3

I always use CLv2. That’s because:

  • IATI v2.0x codelists are available in CLv1, CLv2 and CLv3
  • IATI v1.0x codelists are available in CLv1 and CLv2

So CLv2 is the most recent codelist API version that’s universally available.

I guess I’ll continue to do so after IATI v1.0x is deprecated, because I will probably still sometimes need to parse v1.0x data.

If IATI v1.0x codelists were available in CLv3, I would always use that. Here is a ticket about this.

+1.

1 Like
(Herman van Loon) #4

Hi Amy,
Thanks for asking. We only use CLv3.

Regards
Herman

(Andy Lulham) #5

I’ve just sent some pull requests (here and here) to make IATI v1.0x codelists available in CLv3. I realise v1.0x is due to be deprecated, and publishers should certainly be discouraged from publishing v1.0x data. But v1.0x data will probably still be floating around for a bit longer, so we should still endeavour to make it easy to use.

Also: I wonder if you have server monitoring set up, so you can see how often different codelist versions are downloaded? That would help quantify how widely used the different codelist versions are, but would probably also provide generally useful analytics.

2 Likes
Datastore update?
(Siem Vaessen) #6

OIPA makes use of CLv1. Will add impact of moving to CLv3 in Maintenance Board.